Luke – Incompatible format version: 2 expected 1 or lower

I was trying to analyze my Lucene index generated by Nutch and I was getting this error when I selected Lucene index directory

Incompatible format version: 2 expected 1 or lower
And on the console it had

org.apache.lucene.index.CorruptIndexException

I got away with this using latest Luke Jar (luke-all-1.0.1). You can download it from
http://code.google.com/p/luke/downloads/detail?name=lukeall-1.0.1.jar

3 thoughts on “Luke – Incompatible format version: 2 expected 1 or lower

  1. Herbert

    luke might not yet support lucene 3, go back to lucene 2.9 (both the library for indexing and the setting in the indexer).

    Good luck.

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *